$re = '/^\(?([0-9]{3})\)?([ .-]?)([0-9]{3})\2([0-9]{4})$/';
$str = '(595) 123 1234';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);