$re = '/.*([0-9]{5})/';
$str = 'D012345
D012345AS
D012345RM-67
D12345D
12345D67-foo98765
TEST-Str12345ing-rm6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);