// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\D+(\d+\.\d+\.\d+)\D+\d{4}-\d{4}\D+").unwrap();
let string = "Pygments version 2.0.19, (c) 2006-2014 by Georg Brandl";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}