#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\/\*\s*)(?'comment'.*?)(\s*\*\/)"
Local $sString = "/***************************** Шапка Ñтраницы *********************************/" & @CRLF & _
"/*****/" & @CRLF & _
"/*----------------------------------------------------------------------------------------------------------------------*/" & @CRLF & _
"/*----------------------------------------------------------------------------------------------------------------------*/" & @CRLF & _
"/*------ ------*/" & @CRLF & _
"/*------ Внимание! Ðтот файл Ñодержит огромное количеÑтво Ñтилей ------*/" & @CRLF & _
"/*------ Ðе пытайтеÑÑŒ найти здеÑÑŒ что-то вручную ------*/" & @CRLF & _
"/*------ Ð”Ð»Ñ Ð¿Ð¾Ð¸Ñка Ð½Ð°Ð·Ð²Ð°Ð½Ð¸Ñ Ð½ÑƒÐ¶Ð½Ð¾Ð³Ð¾ ÑÑ‚Ð¸Ð»Ñ Ð¸Ñпользуйте Firebug: ------*/" & @CRLF & _
"/*------ http://articles/chto-takoe-firebug-i-pochemu-ego-objazatelno-nado-ustanovit.html ------*/" & @CRLF & _
"/*------ ------*/" & @CRLF & _
"/*------ Краткое руководÑтво по Ñозданию шаблона: ------*/" & @CRLF & _
"/*------ http://articles/sozdanie-shablona.html ------*/" & @CRLF & _
"/*------ ------*/" & @CRLF & _
"/*----------------------------------------------------------------------------------------------------------------------*/" & @CRLF & _
"/*----------------------------------------------------------------------------------------------------------------------*/" & @CRLF & _
"" & @CRLF & _
"/*" & @CRLF & _
"tttttttttttttt" & @CRLF & _
"*/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")