use strict;
my $str = '<a href="//10.1.1.175/Intranetv2/content_kostenstellen.php" style="margin-top:10px; background-color:#800000; border-color:#800000;" class="btn btn-warning">Kostenstellen</a>';
my $regex = qr/#[0-9a-fA-F]{6,6};/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";