#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)}}\s+({{If [\s\S]*?{{EndIf}})"
Local $sString = "{{If "{{Line}}" != ""}}" & @CRLF & _
" {{If "{{Line}}" != ""}}" & @CRLF & _
" <li id="{{Required:Id}}" class="menuEntry line">" & @CRLF & _
" {{EndIf}}" & @CRLF & _
" <li id="{{Required:Id}}" class="menuEntry line">" & @CRLF & _
"{{EndIf}}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")