$re = '`(?<!\$)#.*$(*SKIP)(*F)|\brm\b`m';
$str = ' "$#" #rm
# rm
rm # rm
rm
"rm "
\'rm \'
`rm `
{rm }
$# rm # rm
rm rm # rm
rm # rm rm
rmremovermlink';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);