#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)<script[^>]*>[^\0]*?<\/script>"
Local $sString = "<!doctype html>" & @CRLF & _
"<html>" & @CRLF & _
" <head>" & @CRLF & _
" <title>Testing</title>" & @CRLF & _
" <script src="htttp://..."></script>" & @CRLF & _
" </head>" & @CRLF & _
" <body>" & @CRLF & _
" <img />" & @CRLF & _
" <!-- and so on -->" & @CRLF & _
" </body>" & @CRLF & _
"</html>" & @CRLF & _
"<script>" & @CRLF & _
" function f(){" & @CRLF & _
" if (2 < 5) {" & @CRLF & _
" // ..." & @CRLF & _
" };" & @CRLF & _
" };" & @CRLF & _
"</script>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)