use strict;
my $str = 'Put server in Maintenance mode for FC1.2 Deployment at 13:30:00 GMT-0500 (Mountain Daylight Time) on Thu Jun 29 2023';
my $regex = qr/(Put server in Maintenance mode for .* at )\d{2}:\d{2}:\d{2}/mp;
my $subst = '$1 13:30:00';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";