#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=/|^)(?!\.\.(?![^/]))[^/\n]+/(?R)?\.\.(?:/|$)"
Local $sString = "folders/folder1/folder5/../../folder2" & @CRLF & _
" -> "folders/folder2"" & @CRLF & _
"folders/folder1/../../../folder2" & @CRLF & _
" -> "../folder2"" & @CRLF & _
"folders/folder1/folder5/../folder2" & @CRLF & _
" -> "folders/folder1/folder2""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)