use strict;
my $str = 'folders/folder1/folder5/../../folder2
-> "folders/folder2"
folders/folder1/../../../folder2
-> "../folder2"
folders/folder1/folder5/../folder2
-> "folders/folder1/folder2"';
my $regex = qr~(?<=/|^)(?!\.\.(?![^/]))[^/\n]+/(?R)?\.\.(?:/|$)~mp;
my $subst = '';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";