package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b'`)
var str = `"this is a 'test' there is another 'test'"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}