# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(app)(\d+)/proxy_pass http:\/\/127.0.0.1:808$2\/$1$2;/g;t' <<< "app1
app2"