use strict;
my $str = 'app1
app2';
my $regex = qr/(app)(\d+)/p;
my $subst = 'proxy_pass http://127.0.0.1:808$2/$1$2;';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";