#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(Test results for mic0\n)( Test .+: passed\n){9}"
Local $sString = "http://sid-buildstore.pdx.intel.com/mpss-4/4.4/ci/MPSS-4-CI-4.4.0.3110/eng/internal/rhel7.2/test/rhel7.2/x86_64/systools_test-4.4.0-3110.x86_64.rpm"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")