using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Test results for mic0\n)( Test .+: passed\n){9}";
string input = @"http://sid-buildstore.pdx.intel.com/mpss-4/4.4/ci/MPSS-4-CI-4.4.0.3110/eng/internal/rhel7.2/test/rhel7.2/x86_64/systools_test-4.4.0-3110.x86_64.rpm";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}