package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(Test results for mic0\n)( Test .+: passed\n){9}`)
var str = `http://sid-buildstore.pdx.intel.com/mpss-4/4.4/ci/MPSS-4-CI-4.4.0.3110/eng/internal/rhel7.2/test/rhel7.2/x86_64/systools_test-4.4.0-3110.x86_64.rpm`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}