re = /(Test results for mic0\n)( Test .+: passed\n){9}/m
str = 'http://sid-buildstore.pdx.intel.com/mpss-4/4.4/ci/MPSS-4-CI-4.4.0.3110/eng/internal/rhel7.2/test/rhel7.2/x86_64/systools_test-4.4.0-3110.x86_64.rpm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end