package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:http:\/\/)?(?:www\.)?(.*?)\/(.+?)(?:\/|\?|\#|$|\n)`)
var str = `http://www.site.com/valid_uri?query=string#hash
http://www.site.com/valid_uri?query=string#hash
www.site.com/valid_uri?query=string
site.com/valid_uri?query=string
bolsademulher.com/valid_uri
bolsademulher.com/
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}