# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\b\d+\b).*\1"
test_str = ("#3#6796#\n"
"#8226#16#\n"
"#8227#16#\n"
"#8256#8033#\n"
"#8254#8256#8033#\n"
"#8270#8256#8033#\n"
"#8272#8256#8033#\n"
"#8242#8081#\n"
"#8241#8242#8081#\n"
"#8243#8242#8081#\n"
"#8254#8242#8081#\n"
"#8265#8242#8081#\n"
"#8241#8241#8081#\n"
"#8243#8242#8243#\n"
"#8254#8242#8254#\n"
"#8081#8242#8081#\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.