$re = '/(?:^| )+((\w*?[^ :,\w]+?\w*?)*)(?: |,|: |$)/';
$str = 'I love the following cookies: $cookie[1], $cookie[2, @cookie, @cookie%, hot@dog';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);