import Foundation
let pattern = #"<span class="ccd">[^<]*<\/span>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<td class="col-2">
5 doors, 6 Speed manual,
<span class="pc">
from £24,270
</span>
<span class="ccd">
from £24,215
</span>
<a href="/fleet/company-tax?modelId=1353&trimId=1365&derivativeId=1366" class="tax-calculator ccd vw-btn btn-no-border"><span class="vw-icon-link-small">Get a company car tax quote</span></a>
<br>
5 doors, 7 Speed auto DSG,
<span class="pc">
from £25,685
</span>
<span class="ccd">
from £25,630
</span>
<a href="/fleet/company-tax?modelId=1353&trimId=1365&derivativeId=1374" class="tax-calculator ccd vw-btn btn-no-border"><span class="vw-icon-link-small">Get a company car tax quote</span></a>
<br>
</td>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)