$re = '/(?<!\d)\d(?!\d)/m';
$str = 'a1 cat
Call agent 7, pronto!
a1 101 2 cat 3.
1 a22 2 101 x4y
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);