# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w{3}) {1,2}(\d{1,2}) (\d{2}):(\d{2}):(\d{2})/strftime("%FT%T", $5, $4, $3, $2, $1, (localtime(time))[5])/;t' <<< "Jun 19 02:59:46 org.apache.catalina.core.ApplicationContext log
INFO: Closing Spring root WebApplicationContext
Jun 9 02:59:46 org.apache.catalina.core.ApplicationContext log
INFO: Closing Spring root WebApplicationContext"