$re = '/(\w{3}) {1,2}(\d{1,2}) (\d{2}):(\d{2}):(\d{2})/';
$str = 'Jun 19 02:59:46 org.apache.catalina.core.ApplicationContext log
INFO: Closing Spring root WebApplicationContext
Jun 9 02:59:46 org.apache.catalina.core.ApplicationContext log
INFO: Closing Spring root WebApplicationContext';
$subst = "strftime(\"%FT%T\", $5, $4, $3, $2, $1, (localtime(time))[5])";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;