#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:^|[^\d.])(0(?:\.\d{0,2})?|1(?:\.0{0,2})?)(?=([^\d.]|$))"
Local $sString = "0.00" & @CRLF & _
"1.00" & @CRLF & _
"2.0" & @CRLF & _
"1.01" & @CRLF & _
"0.02" & @CRLF & _
"0.04" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")