use strict;
my $str = 'COMMENT ON COLUMN "vendor"."things_andstuf_associa
tions"."id" IS \'The unique identifier for a things
andstuf association record.\';
COMMENT ON COLUMN "vendor"."things_andstuf_associa
tions"."course_id" IS \'Identifies the course.\';
COMMENT ON COLUMN "vendor"."things_andstuf_associa
tions"."created_at" IS \'Timestamp of when the reco
rd was created.\';';
my $regex = qr/(?m)(?<=^.{50})\r?\n/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";