# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)(?<=^.{50})\r?\n"
test_str = ("COMMENT ON COLUMN \"vendor\".\"things_andstuf_associa\n"
"tions\".\"id\" IS 'The unique identifier for a things\n"
"andstuf association record.';\n\n"
"COMMENT ON COLUMN \"vendor\".\"things_andstuf_associa\n"
"tions\".\"course_id\" IS 'Identifies the course.';\n"
"COMMENT ON COLUMN \"vendor\".\"things_andstuf_associa\n"
"tions\".\"created_at\" IS 'Timestamp of when the reco\n"
"rd was created.';")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.