package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[A-Z]{3}+-[0-9]{3}$`)
var str = `AAB-456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}