import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h3>(.+?)\\<\\/h3>\\s*<h4>(.+)<\\/h4>\\s*<dl>\\s*<dt>(.+)<\\/dt>\\s*<dd>(.+)<\\/dd>";
final String string = "<h3>Z's(矢沢永吉)</h3>\n"
+ " <h4>Z's TOUR 2015</h4>\n\n"
+ " <dl>\n"
+ " <dt><img src=\"/event/img/btn_day.png\" alt=\"公演日時\" width=\"92\" height=\"20\"> </dt>\n"
+ " <dd>\n"
+ " <table width=\"99%\" border=\"0\" cellpadding=\"0\" cellspacing=\"0\">\n"
+ " <tbody><tr>\n"
+ " <td width=\"9%\" nowrap=\"nowrap\">2015年6月</td>\n"
+ " <td width=\"74%\">4日 (木) 19:00開演</td>\n"
+ " </tr>\n"
+ " \n"
+ " </tbody></table>\n"
+ " </dd>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}