# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<h3>(.+?)\<\/h3>\s*<h4>(.+)<\/h4>\s*<dl>\s*<dt>(.+)<\/dt>\s*<dd>(.+)<\/dd>"
test_str = ("<h3>Z's(矢沢永吉)</h3>\n"
" <h4>Z's TOUR 2015</h4>\n\n"
" <dl>\n"
" <dt><img src=\"/event/img/btn_day.png\" alt=\"公演日時\" width=\"92\" height=\"20\"> </dt>\n"
" <dd>\n"
" <table width=\"99%\" border=\"0\" cellpadding=\"0\" cellspacing=\"0\">\n"
" <tbody><tr>\n"
" <td width=\"9%\" nowrap=\"nowrap\">2015年6月</td>\n"
" <td width=\"74%\">4日 (木) 19:00開演</td>\n"
" </tr>\n"
" \n"
" </tbody></table>\n"
" </dd>")
matches = re.search(regex, test_str, re.DOTALL | re.UNICODE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.