// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?su)<h3>(.+?)\<\/h3>\s*<h4>(.+)<\/h4>\s*<dl>\s*<dt>(.+)<\/dt>\s*<dd>(.+)<\/dd>").unwrap();
let string = "<h3>Z's(矢沢永吉)</h3>
<h4>Z's TOUR 2015</h4>
<dl>
<dt><img src=\"/event/img/btn_day.png\" alt=\"公演日時\" width=\"92\" height=\"20\"> </dt>
<dd>
<table width=\"99%\" border=\"0\" cellpadding=\"0\" cellspacing=\"0\">
<tbody><tr>
<td width=\"9%\" nowrap=\"nowrap\">2015年6月</td>
<td width=\"74%\">4日 (木) 19:00開演</td>
</tr>
</tbody></table>
</dd>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}