package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^.*?([^\d])\.`)
var str = `Lorem 1. Foo, 23. Bar loalk fuu. Kakjfas ipsum fuia.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}