const regex = new RegExp('^.*?([^\\d])\\.', '')
const str = `Lorem 1. Foo, 23. Bar loalk fuu. Kakjfas ipsum fuia.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}