#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i).*\b[^\se]+\b.*"
Local $sString = "bed time" & @CRLF & _
"red carpet" & @CRLF & _
"god father" & @CRLF & _
"good game Al's here" & @CRLF & _
"test does this work, yes!" & @CRLF & _
"" & @CRLF & _
"UPPERCASE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")