# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^\s\|]+)\|([^\|]+)\|([^\|]+)//;t' <<< "sample-search-cdn|nz|nz--cdn|||||generic-produce-luxury-gdn|||generic-value|||| "