using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:,)\s|([^=]+=\s[\w@\.\s]+|[\w].+)";
string input = @"prikey = 2, ju = 20150101, name = sdf, email = sdfsdf@naver.com, sub = (한진해운) 2014년도 케미컬 선장, 1항기, 사 채용";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}