package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:,)\s|([^=]+=\s[\w@\.\s]+|[\w].+)`)
var str = `prikey = 2, ju = 20150101, name = sdf, email = sdfsdf@naver.com, sub = (한진해운) 2014년도 케미컬 선장, 1항기, 사 채용`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}