const regex = /(?:,)\s|([^=]+=\s[\w@\.\s]+|[\w].+)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:,)\\s|([^=]+=\\s[\\w@\\.\\s]+|[\\w].+)', 'gmi')
const str = `prikey = 2, ju = 20150101, name = sdf, email = sdfsdf@naver.com, sub = (한진해운) 2014년도 케미컬 선장, 1항기, 사 채용`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}