$re = '/(http(s)?:\/\/)?(.*\\\\.)?partselect.com\/PS.*(htm|html)((?!Page=\d{1,3}#Central_Content_PagerTop).)*$/m';
$str = 'https://www.partselect.com/PS11741913-Whirlpool-WP37001042-Drum-Support-Roller-for-square-ported-models.htm?Page=0#Central_Content_PagerTop
https://www.partselect.com/PS4138718-Samsung-DA34-00006C-Light-Door-Switch.htm?SourceCode=19&SearchTerm=&ModelNum=BBF19KASWXAC
https://www.partselect.com/PS9172714-MTD-954-04032B-Belt-3L-X-35-80.htm?SourceCode=18';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);