# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"/\d{8}/"
test_str = ("https://cdn.mydomain.com/wp-content/uploads/2020/05**/20125258/**image1.jpg\n"
"https://cdn.mydomain.com/wp-content/uploads/2021/10**/13440323/**image-ex2.jpg\n"
"https://cdn.mydomain.com/wp-content/uploads/2012/01**/92383422/**my-image3.jpg")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.