// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"/\d{8}/").unwrap();
let string = "https://cdn.mydomain.com/wp-content/uploads/2020/05**/20125258/**image1.jpg
https://cdn.mydomain.com/wp-content/uploads/2021/10**/13440323/**image-ex2.jpg
https://cdn.mydomain.com/wp-content/uploads/2012/01**/92383422/**my-image3.jpg";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}