import Foundation
let pattern = #"/\d{8}/"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
https://cdn.mydomain.com/wp-content/uploads/2020/05**/20125258/**image1.jpg
https://cdn.mydomain.com/wp-content/uploads/2021/10**/13440323/**image-ex2.jpg
https://cdn.mydomain.com/wp-content/uploads/2012/01**/92383422/**my-image3.jpg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)