# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)^([A-Za-z][0-9]{1,2})|(([A-Za-z][A-Za-z][0-9]{1,2})|(([AZa-z][0-9][A-Za-z])|([A-Za-z][A-Za-z][0-9][A-Za-z]?)))? ?[0-9][A-Za-z]{2}$"
test_str = ("Ivy Cottage, Rockley,SN81RT\n"
"11 Brabourne Gardens, North Shields,NE299JB\n"
"2 Russell Gardens, Whitchurch,RG287AY\n"
"14 Red Barns, Newcastle Upon Tyne,NE12TP\n"
"1 Hollybank, Tamworth Road, Lichfield,WS149JE\n"
"69 Burnlee Road, Holmfirth,HD92PS\n"
"30 Cashio Lane, Letchworth Garden City,SG61AX\n"
"14 Cedartree Gardens, Whitley Bay,NE258XN\n"
"518A Victoria Road, Ruislip,HA40HD\n"
"9 Pear Avenue, Leeds,LS168GT\n")
subst = "$0@"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.