$re = '/8[5,8][0-9]{3}/';
$str = '54128';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);