#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+\s?(X|x)|\s?\d+"
Local $sString = "1234 x 2343" & @CRLF & _
"" & @CRLF & _
"123x" & @CRLF & _
"" & @CRLF & _
"x123" & @CRLF & _
"" & @CRLF & _
"123 x" & @CRLF & _
"" & @CRLF & _
"x 123" & @CRLF & _
"" & @CRLF & _
"123X 123" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")