#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[(?P<a>[0-9]*)\/(?P<b>[0-9]*-[0-9]*)@g.us\((?P<c>(?:[0-9]{2}\-){2}2015) [0-9]{2}:[0-9]{2}\)\]:\[(?P<d>[A-Z0-9a-z]{13}|.*)\](?P<e>.*)\nMessage (?P=d): Sent delivered receipt\n\[connected]:"
Local $sString = "[1234567890123/123456789012-1234567898@g.us(18-10-2015 11:30)]:[AC103CD12DER5] VW Simulator" & @CRLF & _
"Message AC103CD12DER5: Sent delivered receipt" & @CRLF & _
"[connected]:" & @CRLF & _
"" & @CRLF & _
"[1234567890123/123456789012-1234567898@g.us(18-10-2015 11:30)]:[AC103CD12DER5] VW Simulator" & @CRLF & _
"Message AC103CD12DER5: Sent delivered receipt" & @CRLF & _
"[connected]:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")