import re
regex = re.compile(r"\[(?P<a>[0-9]*)\/(?P<b>[0-9]*-[0-9]*)@g.us\((?P<c>(?:[0-9]{2}\-){2}2015) [0-9]{2}:[0-9]{2}\)\]:\[(?P<d>[A-Z0-9a-z]{13}|.*)\](?P<e>.*)\nMessage (?P=d): Sent delivered receipt\n\[connected]:")
test_str = ("[1234567890123/123456789012-1234567898@g.us(18-10-2015 11:30)]:[AC103CD12DER5] VW Simulator\n"
"Message AC103CD12DER5: Sent delivered receipt\n"
"[connected]:\n\n"
"[1234567890123/123456789012-1234567898@g.us(18-10-2015 11:30)]:[AC103CD12DER5] VW Simulator\n"
"Message AC103CD12DER5: Sent delivered receipt\n"
"[connected]:")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")