using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(e[0-9]r[0-9]{1,2}p[0-9]{1,2})";
string input = @"e2r1p1.42.fr";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}