package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`__(\d+)(\.\d+)*__`)
var str = `__1.23.1__
__1.2__
__1.__
__12__
__.4__
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}